MarkAble FAQs


I installed ios 8.4 and now audiobooks aren’t in music app. Do you have a solution to the problem? I hope so!


Audiobooks have moved to the iBooks app. If you had them installed via iTunes, they should show up there.


I started with five large audio files and told MarkAble to break the final book up into two parts.  How come I end up with one part much bigger than the other?


I converted a single audio file and told MarkAble to split it into two parts.  It didn’t work!


Perhaps I need to make it clear that MarkAble doesn’t (can’t) SPLIT audio files.  The ‘number of parts’ thing is really predicated on there being lots of small source files.  Think of the source files as playing cards.   You can’t have a greater number of players than the number of cards, or some players are going to go without cards.

When you change the number of parts, MarkAble ‘deals’ the files to that number of players (parts), trying to give every player a roughly similar number of cards.  Like any good card dealer, it doesn’t rip cards in half to make things nice and even.


The software issues a software ping each time it processes a file. Can I turn this off somehow? Its a bit annoying.


It’s not me!  It’s iTunes doing this, and though I’ve hunted on the Internet, there doesn’t seem to be any easy way of stopping it.

MarkAble 2.2.0 introduced a preference (under ‘Preferences/Misc’) which lets it mute all computer sound while it is ripping.  This effectively hides the iTunes sound (but also mutes all other sound such as from games, music, etc, each time a track or file is being converted).  It restores the volume at the end of each track conversion.

Another solution, provided by Matthew Mason (thanks!) is as follows:

I looked in and found a file in iTunes called complete.wav
it was in Program Files (x86)\iTunes\iTunes.Resources. I just renamed the file and now that noise is gone.


When will MarkAble be able to handle creating very large AAC files (eg 1 GB or greater)?


There are some fundamental limitations built in to the AAC standard (and worse, in Apple’s firmware) which cause problems with very large (well, long duration) audiobook files.

If you can bear with me (and the math), I’d like to explain once and for all what seems to be the problem.

* The AAC standard specifies an UNSIGNED 4-byte integer for the duration field.  The largest number which can be stored in such a field is 2 ^ ( 4 * 8 ) = 2 ^ 32 = 4,294,967,296.

* This is NOT a value measured in seconds!  It is the total number of ‘time units’. For audio, this means the number of audio SAMPLES.

* If you encode at typical settings, there are 44,100 samples per second.* Now students, what is the longest duration you can store in an unsigned 4-byte integer if you are encoding at 44,100 samples per second?4,294,967,296 / 44,100 ~= 97,392 seconds ~= 1,623 minutes ~= 27 hours* Hooray!  27 hours is a pretty big audiobook.

* BUT….. for reasons known only to Apple, QuickTime and iTunes expect a SIGNED four byte integer in the duration field.  The maximum number which can be stored in a SIGNED integer is HALF that of an unsigned integer because it has to range from negative 2,147,483,647 to positive 2,147,483,647.

* So the longest duration you can store in a SIGNED 4-byte integer if you are encoding at 44,100 samples per second is: 2,147,483,647 / 44,100 ~= 48,696 seconds ~= 811 minutes ~= 13.5 hoursThere’s no getting away from this math.  If you want longer audiobooks, you have to encode at a lower sampling rate (NOTE this is NOT the same as the bit rate).So if you encoded at 22,000 samples per second, you could double the length of the AAC file.  At 11,000 samples per second, quadruple it.  But of course, the quality goes down.

Later edit (25 Feb 2010): It seems that iTunes now accepts unsigned integers for the duration and so will play longer duration files (up to 27 hours).  But the limitation remains in QuickTime.


When MarkAble tries to rip a disc, I get a message ‘iTunes is not responding to MarkAble control’ and nothing happens.


I’m pretty sure that this is caused by a bad installation of iTunes.  iTunes appears to operate correctly, but it hasn’t correctly installed the bit that it allows it to be controlled by other applications like MarkAble.

My advice is to UNINSTALL iTunes completely (don’t worry, your iTunes library will be safe), then download the latest version from Apple and reinstall.


What does running a batch file mean?  Does that mean I can convert more than one book at a time?


Yes. This is how it works:

* From the MarkAble main screen, choose ‘Other File Formats’.FOR EACH BOOK:

Step1:  Drag and drop, or use ‘Select Files’ or ‘Select Folder’ to add the files for a particular book or program.

Step 2: On the next screen, sort into order if necessary

Steps 3-5: Fill in the title of the book or program, and the creator, etc.

Steps 6-7: Set the number of parts, how you want chapters inserted, and select an image for cover artwork.

Important!! Click on ‘Add to Batch’ rather than ‘Process Now’.You’ll be prompted for a file name and location.  Keep choosing the same file to keep adding to the current batch.

Keep cycling through the above loop until you have added all the books or programs you want to process in one batch.TO RUN THE BATCH:

Choose ‘Other File Formats’ from the main screen.

On the next screen, choose ‘Run Batch’ without adding any files to the file list.

You’ll be prompted for the batch file you created earlier.

That’s it – go away for a long time while it does its tricks.

Basically, you do everything you would normally do to process a bunch of files into an  audiobook, but you just keep hitting ‘Add to Batch’ rather than immediately processing.

Question: I’ve used MarkAble to put chapter stops in my audiobooks, but when I play them in iTunes, I don’t see any chapter marks.

Answer: ITunes shows the chapters in a funny way.  You get an additional top menu choice called ‘Chapters’ after you start playing an audiobook.  It gives you a drop-down list of the chapters: